summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CREDITS1
-rw-r--r--ChangeLog5
-rw-r--r--INSTALL15
-rw-r--r--Makefile.in3
-rw-r--r--configure.in50
5 files changed, 59 insertions, 15 deletions
diff --git a/CREDITS b/CREDITS
index 255bd112..f0d22530 100644
--- a/CREDITS
+++ b/CREDITS
@@ -13,6 +13,7 @@ Dan Brosemer <odin@linuxfreak.com> - Autoconf support, build fixes
Darren Hall <dhall@virage.org> - AIX patches
David Agraz <dagraz@jahoopa.com> - Build fixes
David Rankin <drankin@bohemians.lexington.ky.us> - libwrap, NetBSD fixes
+Holger Trapp <Holger.Trapp@Informatik.TU-Chemnitz.DE> - KRB4/AFS config patch
Jani Hakala <jahakala@cc.jyu.fi> - Patches
Jim Knoble <jmknoble@pobox.com> - Many patches
jonchen (email unknown) - the original author of PAM support of SSH
diff --git a/ChangeLog b/ChangeLog
index 76b692c9..ba9bc65a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+20000106
+ - Documentation update & cleanup
+ - Better KrbIV / AFS detection, based on patch from:
+ Holger Trapp <Holger.Trapp@Informatik.TU-Chemnitz.DE>
+
20000105
- Fixed annoying DES corruption problem. libcrypt has been
overriding symbols in libcrypto. Removed libcrypt and crypt.h
diff --git a/INSTALL b/INSTALL
index 5e0b5c8f..0f86610c 100644
--- a/INSTALL
+++ b/INSTALL
@@ -109,12 +109,15 @@ it if lastlog is installed in a different place.
--without-lastlog will disable lastlog support entirely.
---with-kerberos4 will enable Kerberos IV support. You will need to
-have the Kerberos libraries and header files installed for this to
-work.
-
---with-afs will enable AFS support. You will need to have the Kerberos
-IV and the AFS libraries and header files installed for this to work.
+--with-kerberos4=PATH will enable Kerberos IV support. You will need
+to have the Kerberos libraries and header files installed for this
+to work. Use the optional PATH argument to specify the root of your
+Kerberos installation.
+
+--with-afs=PATH will enable AFS support. You will need to have the
+Kerberos IV and the AFS libraries and header files installed for this
+to work. Use the optional PATH argument to specify the root of your
+AFS installation. AFS requires Kerberos support to be enabled.
--with-skey will enable S/Key one time password support. You will need
the S/Key libraries and header files installed for this to work.
diff --git a/Makefile.in b/Makefile.in
index d04d22de..23f00582 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -21,7 +21,6 @@ CFLAGS=@CFLAGS@ $(PATHS) @DEFS@
EXTRA_TARGETS=@GNOME_ASKPASS@
TARGETS=libssh.a ssh sshd ssh-add ssh-keygen ssh-agent scp $(EXTRA_TARGETS)
LIBS=@LIBS@
-LIBWRAP=@LIBWRAP@
AR=@AR@
RANLIB=@RANLIB@
INSTALL=@INSTALL@
@@ -72,7 +71,7 @@ ssh: $(SSHOBJS) libssh.a
$(CC) -o $@ $(SSHOBJS) $(LDFLAGS) -lssh $(LIBS)
sshd: $(SSHDOBJS) libssh.a
- $(CC) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh $(LIBS) $(LIBWRAP)
+ $(CC) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh $(LIBS)
scp: scp.o libssh.a
$(CC) -o $@ scp.o $(LDFLAGS) -lssh $(LIBS)
diff --git a/configure.in b/configure.in
index 7480349a..127cd055 100644
--- a/configure.in
+++ b/configure.in
@@ -52,6 +52,7 @@ case "$host" in
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_HPUX_TRUSTED_SYSTEM_PW)
LIBS="$LIBS -lsec"
+ AC_MSG_WARN([This configuration is untested])
else
AC_MSG_RESULT(no)
AC_DEFINE(DISABLE_SHADOW)
@@ -60,6 +61,9 @@ case "$host" in
*-*-solaris*)
AC_DEFINE(USE_UTMPX)
;;
+*-*-aix*)
+ AFS_LIBS="-lld"
+ ;;
*-*-irix5*)
no_libsocket=1
no_libnsl=1
@@ -400,23 +404,56 @@ AC_TRY_LINK([],
dnl Check whether user wants Kerberos support
AC_ARG_WITH(kerberos4,
- [ --with-kerberos4 Enable Kerberos 4 support],
+ [ --with-kerberos4=PATH Enable Kerberos 4 support],
[
if test "x$withval" != "$xno" ; then
+
+ if test "x$withval" != "$xyes" ; then
+ CFLAGS="$CFLAGS -I${withval}/include"
+ LDFLAGS="$LDFLAGS -L${withval}/lib"
+ else
+ if test -d /usr/include/kerberosIV ; then
+ CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
+ fi
+ fi
+
+ AC_CHECK_HEADERS(krb.h)
+ AC_CHECK_LIB(krb, main)
+ if test "$ac_cv_header_krb_h" != yes; then
+ AC_MSG_WARN([Cannot find krb.h, build may fail])
+ fi
+ if test "$ac_cv_lib_krb_main" != yes; then
+ AC_MSG_WARN([Cannot find libkrb, build may fail])
+ fi
+
+ LIBS="$LIBS -lkrb -ldes"
+ AC_CHECK_LIB(resolv, dn_expand, , )
+ KRB4=yes
AC_DEFINE(KRB4)
- LIBS="$LIBS -lkrb"
- CFLAGS="$CFLAGS -I/usr/include/kerberosIV"
fi
]
)
dnl Check whether user wants AFS support
AC_ARG_WITH(afs,
- [ --with-afs Enable AFS support],
+ [ --with-afs=PATH Enable AFS support],
[
if test "x$withval" != "$xno" ; then
- AC_DEFINE(AFS)
+
+ if test "x$withval" != "$xyes" ; then
+ CFLAGS="$CFLAGS -I${withval}/include"
+ LFLAGS="$LFLAGS -L${withval}/lib"
+ fi
+
+ if test -z "$KRB4" ; then
+ AC_MSG_WARN([AFS requires Kerberos IV support, build may fail])
+ fi
+
LIBS="$LIBS -lkafs"
+ if test ! -z "$AFS_LIBS" ; then
+ LIBS="$LIBS $AFS_LIBS"
+ fi
+ AC_DEFINE(AFS)
fi
]
)
@@ -438,11 +475,10 @@ AC_ARG_WITH(tcp-wrappers,
[
if test "x$withval" != "$xno" ; then
AC_DEFINE(LIBWRAP)
- LIBWRAP="-lwrap"
+ LIBS="$LIBS -lwrap"
fi
]
)
-AC_SUBST(LIBWRAP)
dnl Check whether to enable MD5 passwords
AC_ARG_WITH(md5-passwords,