summaryrefslogtreecommitdiff
path: root/INSTALL
diff options
context:
space:
mode:
authorBen Lindstrom <mouring@eviladmin.org>2000-11-10 02:41:30 +0000
committerBen Lindstrom <mouring@eviladmin.org>2000-11-10 02:41:30 +0000
commit305fb0018a1485a040eac264527b3fd4557a461a (patch)
tree731fd59b242eddc0560c712cb8c7652e0301f3d4 /INSTALL
parentdbcea870630e6e6cedc6937d33da4e2e4c6d5390 (diff)
20001110
- (bal) Fixed dropped answer from skey_keyinfo() in auth1.c - (bal) Changed from --with-skey to --with-skey=PATH in configure.in - (bal) Added in check to verify S/Key library is being detected in configure.in - (bal) next-posix.h - added another prototype wrapped in POSIX ifdef/endif. Patch by Mark Miller <markm@swoon.net> - (bal) Added 'util.h' header to loginrec.c only if HAVE_UTIL_H is defined to remove warnings under MacOS X. Patch by Mark Miller <markm@swoon.net> - (bal) Fixed LDFLAG mispelling in configure.in for --with-afs
Diffstat (limited to 'INSTALL')
-rw-r--r--INSTALL10
1 files changed, 8 insertions, 2 deletions
diff --git a/INSTALL b/INSTALL
index 76d17b81..577a667e 100644
--- a/INSTALL
+++ b/INSTALL
@@ -47,6 +47,12 @@ ftp://ftp.cus.cam.ac.uk/pub/software/programs/pcre/
Most platforms do not required this. However older 4.3 BSD do not
have a posix regex library.
+S/Key Libraries:
+http://www.sparc.spb.su/solaris/skey/
+
+If you wish to use --with-skey then you will need the above library
+installed. No other current S/Key library is currently known to be
+supported. (If it fails to compile copy the sha1.h to the openssh directory
2. Building / Installation
--------------------------
@@ -125,8 +131,8 @@ Kerberos IV and the AFS libraries and header files installed for this
to work. Use the optional PATH argument to specify the root of your
AFS installation. AFS requires Kerberos support to be enabled.
---with-skey will enable S/Key one time password support. You will need
-the S/Key libraries and header files installed for this to work.
+--with-skey=PATH will enable S/Key one time password support. You will
+need the S/Key libraries and header files installed for this to work.
--with-tcp-wrappers will enable TCP Wrappers (/etc/hosts.allow|deny)
support. You will need libwrap.a and tcpd.h installed.